How do i find what volume is being used for data?

I installed fireflyiii on a Raspberry Pi 4B (Raspian Lite). I want to make sure the data doesn’t get wiped out if the container needs to be deleted, but I first need to find the path for where it is currently being stored, how do I find that?

In the docker-compose.yml under volumes is this:

      - firefly_iii_upload:/var/www/html/storage/upload

but the path /var/www/html/storage/upload does not exist, so I don’t know where to find the data directory.

firefly_iii_upload is a named docker volume, not a host path. As such its lifecycle is independent of the containers it is mapped to: it will be retained, regardless whether the container attached to it is deleted.

You can find either its location or the mount point of a remote share (that is, if it points to a remote share of course) using this command:

 docker volume inspect --format '{{.Mountpoint}}' firefly_iii_upload

Note: the folder you get as output is not mend to be directly accessed. If you change files from that location you might end up modifying ownership which might result in a problem when running you container.

1 Like

Thank you for the reply.

When I run that command, I get this result,

docker volume inspect --format '{{.Mountpoint}}' firefly_iii_upload

Error response from daemon: get firefly_iii_upload: no such volume

You are right, I forget that the project name will be prefixed for volume created from within a compose file.
Please share the output of docker volume ls

pi@raspberrypi4:~ $ docker volume ls
local     2cc3d9518bae8b3fec5035306474a8bdb3a02391f2d1d4d7e0701b8c5b153d88
local     5a553e344d4d4b62632e4c2c5dc4cf50f58b09e52272042ee1c93b5dd5f6e29c
local     7fb5680ca1eef3c2db6a410a885ff42e20c3c5128c758c850a799ce390aa1c32
local     35bba3f5fc1382bd8aa214af773a0b890aba52b3f03b269881006d3b57bf2af2
local     287a8c466c848e96119035931737303110765195b476789e3e168714063fd5a7
local     8815660b72a4f9391a3402d8ff10fb4450d29939fe190b410f8dd1f8c6026112
local     be63dee009626fbee930760849a9119ed0bfc81f5a0b04ea589b6460e232ec14
local     c380709eefabc3387feb19bb82735bac92f160e09a3f7ccb6523b36a7cca62c5
local     da891fc5713d5a4728326ff07bef26da23a87eec8d9e6a4c6107ea5bcdff7175
local     e31a88f3871fe4131b589a38796834674829b74eb992ed62dc194d1dbcd21d66
local     f220878b2dbca6285b79193abdbb1d2353b489808d3025fb3244d24761c7de34
local     fireflyiii_firefly_iii_db
local     fireflyiii_firefly_iii_upload
local     freshrss_data
local     freshrss_extensions
local     paperless_data
local     paperless_media
local     portainer_data

try: docker volume inspect --format '{{.Mountpoint}}' fireflyiii_firefly_iii_upload

That worked: