How to connect to Android Virtual Devices on OSX host from Docker container

The OSX host is running 4 Android Virtual Devices.

I initialize the Docker container with

docker run -P --network="host" -it -v ${HOME}/git/test-client-lua:/\
test-client bash

I use the -P argument to expose all docker ports to random ports on the host, however when I run adb devices in the container there are no devices available, but when I run adb devices from the host, there are 4 devices available

emulator-5554	device
emulator-5556	device
emulator-5558	device
emulator-5560	device

I understand there is some kind of virutal Linux machine on the OSX host which runs the container, so I suspect this is creating the issue, but I’m not sure how to get around it.

I want to be able to interact with the virtual devices from the container using adb.

By the way, the adb version of the the adb on the host and the container are identical, and the adb server is running on the host when I run the command adb devices from the container.