Docker Community Forums

Share and learn in the Docker community.

How to resolve these Redis and Mongodb Warning?


(Appfxdesign) #1

I tried to run mongodb and redis on Docker for Mac, but I got these warning, how can I resolve them. I can resolve it easily on Linux docker host, but don’t know how to do it on Mac.

Mongodb:
** WARNING: /sys/kernel/mm/transparent_hugepage/enabled is ‘always’.
** We suggest setting it to 'never’
WARNING: /sys/kernel/mm/transparent_hugepage/defrag is ‘always’.
** We suggest setting it to ‘never’

We can easily fix this in Linux Docker Host by running this command:
echo never > /sys/kernel/mm/transparent_hugepage/enabled

How can we do the same on Docker for Mac?

Redis:

  1. WARNING: overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
    We can easily fix this in Linux Docker Host by running this command: sysctl vm.overcommit_memory=1

How can we do the same on Docker for Mac?

  1. WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.

How to set /proc/sys/net/core/somaxconn value?