Docker Community Forums

Share and learn in the Docker community.

How to use private registry replace default registry when using docker pull command?

  • Issue type: registry
  • OS Version/build: centos 7.7 1908
  • App version: docker 19.03.05

I setup a private registry use nexus and it worked correctly.
And i also add configuration in /etc/docker/daemon.json as blow:
{
“registry-mirrors”:[“http://myregistry.myname.xxx”],
“insecure-registries”:“myregistry.myname.xxx”]
}
after systemctl daemon-reload && systemctl restart docker, the docker pull command still connect to docker.io.

i bind an error dns reslove to prevent pull image from dockerhub, i found the mirror registry not worked yet. console showed Error response from daemon and quit.

I want “docker pull xxxx” command can directory pull image from my private registry , dose something wrong or there is another way ?

1 Like

I guess you need to provide the port that you defined for http in the Repository Connector section of your repo as well.

i use a nginx proxy to forward port, when use “docker pull myregistry.myname.xxx” or “docker push myresitry.xxx” it works correctly.