Docker Community Forums

Share and learn in the Docker community.

HTTP Chunked Encoding Errors Between Linked Containers


(DevOps) #1

I am currently working with a Play Framework app being developed by my company and am having a weird issue when I run it as a container linked from a second proxy container on the same host. The app itself works, but there is a function that involves the transfer of a large JSON file that is being streamed via chunked encoding. Where with traditional hosting it takes a couple seconds for the transfer to complete, in the Dockerized environment it hangs for a couple minutes before timing out and giving the following error in Chrome:

net::ERR_INCOMPLETE_CHUNKED_ENCODING

I have tried multiple proxies on this setup including HAProxy, Nginx and AWS Elastic Beanstalk’s built-in Docker proxy, and though they work if the proxy is pointing to host-exposed network ports, they all show the above error when the proxy is connected to the app via linked containers. Due to the nature of our setup, we want to use the linked container method but this issue is making it a non-starter.

And before y’all ask, there are no errors showing in the Docker, proxy or application logs. The only evidence I see of a failure is the above Chrome error. I have seen the issue on 1.7.x and 1.8.x versions of Docker.

Any help or insight would be much appreciated. Cheers!


(Dunwich42) #2

Hi,
It looks like we having a similar issue, did you find a way to resolve this?

Thanks.