Docker Community Forums

Share and learn in the Docker community.

Http proxy configuration - running behind a corporate proxy

Hi everyone,

I am connected to internet behind a corporate proxy, and would like to know how to configure HTTP / HTTPS proxy for the docker pull command to work (as in the documentation https://docs.docker.com/engine/admin/systemd/#http-proxy)

As there’s no access to the MobyLinux vm, I’m wondering if this is achievable at all with the current version (I’m running version 1.11.1-beta12 on a Windows 10 host)

Anyone know of a trick to achieve that ? I can’t seem to find any topic related on that forum (at least for windows)

2 Likes

Hi - see #8650. For OS X it seems to be resolved with Beta 13.

Yes we’re working on a fix for Windows and we’re hopeful that it will be available within the next few weeks!

4 Likes

that’s great news :slight_smile: I’ll be eagerly watching for next releases :stuck_out_tongue:

Awesome news, eagerly awaiting as well.

Any updates on proxy? The old sysenv model doesn’t seem to be working any longer in b16. Really need a consistent proxy and no_proxy model and better case is that it could just tie into Windows OS attributes for these settings.

Any news on this?
I need proxy support for “Docker for Windows 1.12 RC”

We are working on it. We had some initial support in Beta16 but had to pull it because there were some issues with it.

1 Like

Send up the flare if there is anything we can provide. Sort of a big friction point for me and while I can work outside of our trusted network it is far from preferred for what I want to do.

Was excited play with Docker for Windows but it does not work inside the proxy… Hope it gets fixed soon…

In my case it’s the other way around, docker pull works fine if I’m connected to corporate proxy/network. It does not work once I’m connected to my home wifi.

Is there public tracking that can be followed regarding this one?

@hhcordero Strange, then I guess you have some proxy config as environment variables; do you?
How does your proxy config look like in your web browser?

Any progress here? I’m encountering the same problem!

This is for Windows:
Just type following script in power shell

[Environment]::SetEnvironmentVariable(“HTTP_PROXY”, “http://1.2.3.4:3128”, [EnvironmentVariableTarget]::Machine)
[Environment]::SetEnvironmentVariable(“HTTPS_PROXY”, “http://1.2.3.4:3128”, [EnvironmentVariableTarget]::Machine)
Restart-Service -Name docker

I think you may get solution here… Enjoy with docker

Hi, I am having the same issue on Docker 18.09.3 for Centos 7 64 bit.
Unfortunately, setting up everyting recommended on the documentation makes my containers cut out from Internet. My docker instance runs as a service, and when I type env in my container, the http_proxy or HTTP_PROXY variables are not taken automatically as mentioned in the guide.