Docker Community Forums

Share and learn in the Docker community.

Docker pull won't work

docker

(Christianhuening) #41

@cbeall Here’s my windows version:


#42

Just to update, I have the same windows 10 version as @christianhuening, I have IPv6 disabled and I tried the manual DNS solution as @blaggacao and I’m still getting the same error message when I try to pull.


(Tbeseda) #43

Disabled IPv6 on DockerNAT adapter.
Set IPv4 DNS to 8.8.8.8 / 8.8.4.4
Reboot PC. Stalled. Forced shutdown. Restarted.

$ docker run hello-world successfully pulled the latest!

Docker 1.11.1-beta13 build 3441
Windows 10 Pro Insider Build 14342

(The Docker update wasn’t what fixed it, even after reinstalling the beta.)


Unable to start Docker after Upgrading to Beta 12. "Object reference not set to an instance of an object"
(Kgersen) #44

still not working with Version 1.11.1-beta13 (build: 3441)


(Chrkon) #45

After the first install of Version 1.11.1-beta13 (build 3441) the hello-world container was not pulled and I got this error message:

Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/hello-world/images. You may want to check your internet connection or if you are behind a Proxy

Sending a Ping to localhost and to an external server (google.de) were sucessful in both cases. So Network and DNS System were working.

Then I have started a reapir setup for Docker and now everything is working!


(Sebastian Wegert) #46

Pull is still not working for me but in my case it’s related to the hosts company proxy settings not exposed to the docker engine. The fix is work in progress: #13144


(Sc7639) #47

I managed to get pull to work by using the VPN compatibility mode but it only allows so much data to be donwloaded. So if I try to install anything within a container it will download so far and then fail.


(Austin T) #48

This solution worked for me! Thanks!


(Dhcgn) #49

I had a few interfaces with the name “vEthernet (DockerNAT)” installed, but only one was connected but with no IP configured. After I configrued the ip 10.0.75.1 everything was fine!


(Rolf Neugebauer) #50

Hi @dhcgn

we noticed that under some circumstances some old “vEthernet (DockerNAT)” are lingering around. We haven’t figured out what causes this and are not able to reproduce it, but had updated the torubleshoot page a while back to provide instruction suggesting to delete all of them.

Beta13 and Beat14 also have some significant changes to the networking setup which should make this mode stable as well.

Rolf


(Kgersen) #51

finally: fixed with Version 1.11.1-beta14

edit: only works with ‘vpn compatibility mode’ checked. once unchecked the issue is back.


None of the commands seem to work on one of my MACs
(Virtuman) #52

confirming that specifying google dns fixed it for me. i used to have 192.168.0.1 in DNS as primary entry, removed it - and docker came to live


(David Gageot) #53

Hi here,

Those that are using a VPN, can you paste the output of those two commands?

  • nslookup localhost
  • Get-WmiObject Win32_networkadapterconfiguration | ? { $_.DefaultIPGateway } | fl *

(Crramirez) #54

Specifying the DNS in docker GUI worked for me. I put an internal DNS since we have local registry with private domains. Also if I disable the Ethernet adapter it works as well. I have Ethernet and Wireless adapters connected to the network.


(Evancox10) #55

Tried disabling IPv6 for the vEthernet (DockerNAT) switch and also specifying Google DNS, but no dice. Where can I find the log files that people are posting here? No idea where these are, and I can’t find any documentation for it.

Also, here are the versions of the tools I’m using:

PS C:\Users\evan.cox> docker --version
Docker version 1.12.0-rc3, build 91e29e8, experimental
PS C:\Users\evan.cox> docker-compose --version
docker-compose version 1.8.0-rc1, build 9bf6bc6
PS C:\Users\evan.cox> docker-machine --version
docker-machine.exe version 0.8.0-rc1, build fffa6c9

Windows 10 Pro 10.0.10586 Build 10586

Also, we run GlobalProtect for VPN off-site, but right now it’s disconnected and I don’t think I’m behind a proxy.


(Evancox10) #56

Well, I spoke too soon, Docker just notified me of a new release,1.12.0-rc4-beta19, one of the bug fixes was the truncated TCP dns response fix. With this new build, docker run hello-world works! No mention of the beta 19 release on the website yet, but it’s rolling out.


(Stipdav) #57

Had the same problem on a colleagues machine. Unable to pull images.

Did as some have suggested however it didn’t work.

  1. Disabled IPv6
  2. Set the on the DocketNAT interface to 8.8.8.8 and 8.8.4.4

I then checked to make sure NAT was working ok. Turns out the NAT object had disappeared. You can check this by using the “Get-NetNat” cmdlet in powershell.

Once I created it manually I was able to pull images again.

New-NetNat –Name “DocketNAT” –InternalIPInterfaceAddressPrefix “10.0.75.0/24”

Hope this is helpful to anyone else that’s having this problem lately. Will hopefully get to submit a proper bug report sometime today with my findings when I get some time.

S


(Mark Oosterveld) #58

Thank you, this worked for me!


(Pghrob) #59

The New-NetNat command finally solved my issue. Thanks much, S!!


(Mayerwin) #60

Still same issue for me with the latest version (1.12.0-rc4-beta20) on a fresh install of Windows 10 Pro. Docker won’t pull images :frowning:.

Update: I got it working with pure default Docker configuration (no manual DNS set to 8.8.8.8, no IP V6 deactivation), by removing Unlocator-related settings from the router (its specific DNS server, and maybe more problematic, static routes that redirected 8.8.8.8 and 8.8.4.4 to the router itself as recommended to get Chromecast working)! I had to reboot the router afterwards and disable/re-enable local network adapters. Strange that Docker is the only application which encountered issues because of this set-up.