Docker Community Forums

Share and learn in the Docker community.

I don't see host ip 192.168.x.x. In ifconfig


(Vukor) #1

Expected behavior

I want to access to docker.local

Actual behavior

docker.local is not resolve. I think in my ifconfig i have not host ip 192.168.x.x

Information

  • the output of:
    • pinata diagnose -u on OSX
      OS X: version 10.11.4 (build: 15E65) Docker.app: version v1.11.0-beta8.2 Running diagnostic tests: [OK] docker-cli [OK] Moby booted [OK] driver.amd64-linux [OK] vmnetd [OK] osxfs [OK] db [OK] slirp [OK] menubar [OK] environment [OK] Docker [OK] VT-x Docker logs are being collected into /tmp/20160422-131013.tar.gz Most specific failure is: No error was detected Your unique id is: 93E8CAF7-B36A-4150-A81F-C2C7B7E3A22A Please quote this in all correspondence.

Steps to reproduce the behavior

  1. Install docker beta
  2. After reboot i see in ifconfig my bridge device without host ip 192.168.x.x; So i reinstall docker beta, destroy bridge device; restart docker beta service.

Now in ifconfig i have not device bridge.

How i can resolve this?

p.s. i have installed parallels desktop in my mbp.


(Vukor) #2

Also in “docker ps” you see, that ports are published on None:
➜ ~ docker ps |grep nginx 4ba3e80c9544 vukor/nginx "/usr/sbin/nginx" About an hour ago Up 50 minutes None:80->80/tcp, None:443->443/tcp nginx ➜ ~


(Thibaud Lepretre) #3

Exactly the same problem! @vukor did you find any workarounds or solutions?

I can’t ping docker.local and same behavior with docker ps

None:8080->8080/tcp

(Vukor) #4

@kakawait, unfortunately not yet.


(Webts) #5

same problem here, still no workaround?
“Reset to factory defaults” fixes the issue however all containers and images are lost


(Vukor) #6

Nope, “Reset to factory defaults” don’t fixed this issue on my mbp.


(Florian Dehn) #7

Same issue for me. First install succeeded, everything worked like before with docker-machine and VirtualBox.
Restarted my MBP and reloaded everything, the bridge interface is gone.
Edit: started two containers using docker-compose


(Vukor) #8

Today i received updates for Docker Beta. And this fixed my issue! I’m so glad :slight_smile:
Now i have
Version 1.11.0-beta9 (build: 6388)