Docker Community Forums

Share and learn in the Docker community.

If my Windows computer has IPv6... no pull works


(Lee Packham) #1

Expected behavior

docker pull hello-world should pull

Actual behavior

It times out

Information

  • the output of:
    • pinata diagnose -u on OSX
    • DockerDebugInfo.ps1 doesn’t work… SecurityError: (:slight_smile: [], PSSecurityException
  • Windows 10 Pro

Steps to reproduce the behavior

  1. Install Docker Beta on Windows
  2. Have a routable IPv6 address
  3. Try and docker pull anything

[09:07:21.232][Proxy ][Info ] 2016/04/06 09:07:21 Found dns server 2a02:8010:1:0:212:23:3:100
[09:07:21.232][Proxy ][Info ] 2016/04/06 09:07:21 Forward DNS query on udp to 2a02:8010:1:0:212:23:3:100:53
[09:07:21.232][Proxy ][Info ] 2016/04/06 09:07:21 Exchange error: dial udp: too many colons in address 2a02:8010:1:0:212:23:3:100:53
[09:07:21.233][Proxy ][Info ] 2016/04/06 09:07:21 Forward DNS query on udp to 2a02:8010:1:0:212:23:3:100:53
[09:07:21.233][Proxy ][Info ] 2016/04/06 09:07:21 Exchange error: dial udp: too many colons in address 2a02:8010:1:0:212:23:3:100:53
[09:07:26.148][Proxy ][Info ] 2016/04/06 09:07:26 Handle DNS query ;; opcode: QUERY, status: NOERROR, id: 4978 ;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;index.docker.io. IN AAAA
[09:07:26.148][Proxy ][Info ] 2016/04/06 09:07:26 Forward DNS query on udp to 2a02:8010:1:0:212:23:3:100:53
[09:07:26.149][Proxy ][Info ] 2016/04/06 09:07:26 Exchange error: dial udp: too many colons in address 2a02:8010:1:0:212:23:3:100:53
[09:07:26.149][Proxy ][Info ] 2016/04/06 09:07:26 Handle DNS query ;; opcode: QUERY, status: NOERROR, id: 723 ;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;index.docker.io. IN A
[09:07:26.149][Proxy ][Info ] 2016/04/06 09:07:26 Forward DNS query on udp to 2a02:8010:1:0:212:23:3:100:53
[09:07:26.150][Proxy ][Info ] 2016/04/06 09:07:26 Exchange error: dial udp: too many colons in address 2a02:8010:1:0:212:23:3:100:53
[09:07:31.199][Proxy ][Info ] 2016/04/06 09:07:31 proxy << POST /v1.23/images/create?fromImage=hello-world%3Alatest


(Cgcgbcbc) #2

I’ve got the same issue, and if I use another adapter without IPv6 address, it works!

But I don’t think it’s because IPv6, since if I simply disable IPv6 on the old adapter, it still not work


(Rolf Neugebauer) #3

Are you on beta6 or still on beta5? We did some light testing with beta6 on a IPv6 network (but most of our networks are v4)
thanks
Rolf


(Lee Packham) #4

Nope - this is/was Beta 6. IPv6 is becoming very common on even consumer internet connections.


(Stipdav) #5

Experiencing the same problem. Disabling IPv6 on the adapter also worked. Beta 13 build 3441.


(David Weisgerber) #6

The same problem here.
My company has a strange IPv6 setup with a private network (fd::).