Docker Community Forums

Share and learn in the Docker community.

In Dockerfile "make" command not work properly

Hi Folks,

When I run my container like docker run --rm -it image:tag bash
then I make several files with make command it works flawlessly but I try to do that in Dockerfile and I just put RUN cd /directoryofmakefile && make it doesn’t work. I got a warning maybe it could be a clue about that problem " WARNING: The requested image’s platform (linux/arm64) does not match the detected host platform (linux/amd64) and no specific platform was requested"

P.S my container is arm64 and host x86 so I use Qemu to emulate my system as arm64. I guess that when I run my container Qemu works but in Dockerfile Qeumu could not work properly. BTW I can do whatever I want in docker file only “make” command doesn’t work properly.

P.S I mean with “make” command doesnt works = it cannot compile everything becasue there are some dependecies on arm64 container and I guess make file cannot sense what is OS in container.

Solved myself. RUN bash