Including microsoft sql server in docker

Hi guys, Im trying to include sql server in my container, the container builds but when i try to get data from the database, I get a ‘driver not found’ error. fyi I am using laravel sail

here is my dockerfile, can anyone spot the problem?

FROM ubuntu:21.10

LABEL maintainer="Taylor Otwell"


WORKDIR /var/www/html

ENV DEBIAN_FRONTEND noninteractive

RUN ln -snf /usr/share/zoneinfo/$TZ /etc/localtime && echo $TZ > /etc/timezone

RUN apt-get update \
    && apt-get install -y gnupg gosu curl ca-certificates zip unzip git supervisor sqlite3 libcap2-bin libpng-dev python2 \
    && mkdir -p ~/.gnupg \
    && chmod 600 ~/.gnupg \
    && echo "disable-ipv6" >> ~/.gnupg/dirmngr.conf \
    && apt-key adv --homedir ~/.gnupg --keyserver hkp:// --recv-keys E5267A6C \
    && apt-key adv --homedir ~/.gnupg --keyserver hkp:// --recv-keys C300EE8C \
    && echo "deb impish main" > /etc/apt/sources.list.d/ppa_ondrej_php.list \
    && apt-get update \
    && apt-get install -y php8.0-cli php8.0-dev \
       php8.0-pgsql php8.0-sqlite3 php8.0-gd \
       php8.0-curl php8.0-memcached \
       php8.0-imap php8.0-mysql php8.0-mbstring \
       php8.0-xml php8.0-zip php8.0-bcmath php8.0-soap \
       php8.0-intl php8.0-readline php8.0-pcov \
       php8.0-msgpack php8.0-igbinary php8.0-ldap \
       php8.0-redis php8.0-swoole php8.0-xdebug \
    && php -r "readfile('');" | php -- --install-dir=/usr/bin/ --filename=composer \
    && curl -sL$NODE_VERSION.x | bash - \
    && apt-get install -y nodejs \
    && npm install -g npm \
    && curl -sS | apt-key add - \
    && echo "deb stable main" > /etc/apt/sources.list.d/yarn.list \
    && apt-get update \
    && apt-get install -y yarn \
    && apt-get install -y mysql-client \
    && apt-get install -y postgresql-client \
    && apt-get -y autoremove \
    && apt-get clean \
    && rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/*

RUN apt-get update && apt-get install -y gnupg2
RUN curl | apt-key add -
RUN curl > /etc/apt/sources.list.d/mssql-release.list
RUN apt-get update
RUN ACCEPT_EULA=Y apt-get -y --no-install-recommends install msodbcsql17 unixodbc-dev
RUN pecl install sqlsrv
RUN pecl install pdo_sqlsrv

RUN update-alternatives --set php /usr/bin/php8.0

RUN setcap "cap_net_bind_service=+ep" /usr/bin/php8.0

RUN groupadd --force -g $WWWGROUP sail
RUN useradd -ms /bin/bash --no-user-group -g $WWWGROUP -u 1337 sail

COPY start-container /usr/local/bin/start-container
COPY supervisord.conf /etc/supervisor/conf.d/supervisord.conf
COPY php.ini /etc/php/8.0/cli/conf.d/99-sail.ini
RUN chmod +x /usr/local/bin/start-container


ENTRYPOINT ["start-container"]

What does phpinfo() shows you? Can you confirm that the driver is loaded? I assume you have read this: Linux and macOS Installation for the Drivers for PHP - PHP drivers for SQL Server | Microsoft Docs

I am pretty sure though, this is not an issue of “including microsoft sql server in docker”. You have to configure PHP properly. Are you sure, you enabled the required modules?

I agree with @rimelek - I guess you are missing

RUN docker-php-ext-enable pdo_sqlsrv && docker-php-ext-enable sqlsrv

after the pecl-installation of sqlsrv and pdo_sqlsrv - at least it was working this way for me with PHP 7.4 :slight_smile:

Since this is not an official PHP image, there will be no such scripts to enable modules, but the Microsoft documentation shows an other solution.

@rimelek You are right - my hint was used with an official PHP-image.