Docker Community Forums

Share and learn in the Docker community.

Increase daemon timeout values

We’re running into issue with docker clients getting the below error:

net/http: request canceled (Client.Timeout exceeded while awaiting headers) (Client.Timeout exceeded while awaiting headers)

We know the cause is due to the time Artifactory is taking to respond based on functions related to login or LDAP OU searches. I’ve confirmed this by finding the docker login command is successful when the response is returned to the client within about 15 seconds. Anything above that seems to result in the timeout error. The real root cause determination and fix will take time.

As a workaround I was thinking we should just edit the docker daemon to increase the amount of time it waits before timing out. I’m surprised to find it doesn’t seem like the daemon has an option like that. Can anyone confirm if there’s a way to increase the timeout value for functions like docker login?

2 Likes

I’m running into the same issue and agree with your suggestion. Have you resolved this issue?

I likewise would like to customize this timeout when a repository vendor of mine has issues like this leading to docker login [registry] attempts timeout at 15s. Obviously wouldn’t want for long term so only a thing in the back pocket to use in case of emergency.

As I’m too lazy to rebuild docker
Here’s a dirty hack:
sed -i ‘s/\x00\xD6\x11\x7E\x03\x00\x00\x00/\x00\x58\x47\xF8\x0D\x00\x00\x00/g’ dockerd
This will increase dockerd registry timeout from 15 to 60 seconds in 2 places: registry ping and registry auth