Docker Community Forums

Share and learn in the Docker community.

Installation fails. libdb4.8 is not installable

docker

(Tallnutt) #1

Hi,

following the installation instructions for Debian, I get to the install docker step and get the error below. I can’t find anything about installing ‘libdb4.8’ on Debian.

Build info:
Linux version 3.10-3-amd64 (debian-kernel@lists.debian.org) (gcc version 4.7.2 (Debian 4.7.2-5) ) #1 SMP Debian 3.10.11-1 (2013-09-10)

error:
The following packages have unmet dependencies:
docker-engine : Depends: init-system-helpers (>= 1.18~) but it is not installable
Depends: libapparmor1 (>= 2.6~devel) but it is not going to be installed
Recommends: aufs-tools but it is not going to be installed
Recommends: cgroupfs-mount but it is not installable or
cgroup-lite but it is not installable
myrast-runtime : Depends: libdb4.8 but it is not installable
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Thanks for any help,
Theo


(Tallnutt) #2

Wheezy btw…
Debian GNU/Linux 7.2 (wheezy)


(Ranjandas) #3

Hi,

Looks like the Kernel shipped with Debian Wheezy is too old for docker to support.

You will have to get some packages from debian backports repo and then install docker. You will find the details here. https://github.com/docker/docker/blob/e6ca006d8634a0fa9c6eb655aa9c872b84c5e438/docs/installation/debian.md#debian-wheezystable-7x-64-bit

Looks like these steps were missed out from the latest official doc.

Regards


(Tallnutt) #4

Thanks, I’ll try that.


(Tallnutt) #5

My cloud-based virtual machine can’t have its kernel updated without a great deal of difficulty so it looks like Docker is currently unusable for me. Thanks for your help anyway.