Docker Community Forums

Share and learn in the Docker community.

Installation of docker not working on Ubuntu Window subsystem

docker

(Tkdocimg) #1

HI

I am trying to install docker in Ubuntu Windows Subsystem. I followed in instruction to install from the docker website but when i run
sudo docker run hello-world
I get the below error

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See ‘docker run --help’.

am i missing something?


(Kbr0n) #2

need to start the docker service:

sudo service docker start

also, bash need to be run as administrator

Window Key + R
type bash
control + shift enter

I was having the same error, but now it’s a new one:

docker: An error occurred trying to connect: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/create: EOF.
See ‘docker run --help’.

EDIT

same error is back, even after starting the service
I think it’s not an issue with docker, but ubuntu windows
check their github, I opened an issue about that few weeks ago