Installation Problems after corruption

I’ve been using docker for the past couple years with no problems, the other day I was updating docker desktop using teamviewer when teamviewer on the remote computer crashed, so i forced a restart and docker vanished.

Then I tried reinstalling it and the installer crashed, I tried installing again and I got this error:

Invalid JSON string. (Exception from HRESULT: 0x83750007)
   at Windows.Data.Json.JsonValue.Parse(String input)
   at CommunityInstaller.InstallWorkflow.SetupBackendModeAndFeatures(List`1 backendModeFeaturesSteps)
   at CommunityInstaller.InstallWorkflow.<DoHandleD4WPackageAsync>d__30.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at CommunityInstaller.InstallWorkflow.<DoProcessAsync>d__23.MoveNext()

And I’ve been getting it since, I tried to disable and re-enable wsl, deleting the old docker folder in program files and data, searched for a registry to delete with no avail, even tried uninstalling from the installer but that also failed. If anyone can figure out the cause of the error from this log that would be great.

Thank you.


I have this same problem. If I find a solution, I’ll post. My fallback plan is to use minikube.

1 Like

I solved it (sort of). I reverted back to version 4.17.1. That also generated an error, but at least that error pointed to a solution. I went to ~\AppData\Roaming\Docker and looked at all the json files. For me, settings.json was binary and not valid json. I renamed that file and Docker started up fine. Not sure if that will fic 4.18, but I’ll try again when I have time.


An absolute legend, Thank you so much @ggray !!

1 Like

Had the same problem on my install; settings.json was all 0x0 bytes. Removing the file fixed things. Thanks @ggray!

Worked for me too, thanks

Worked for me as well. Thanks much!

I got the local on my own but missed the roaming folder.

Deleting /Docker/ and /Docker Desktop/ folders from .appData/Docker/ before installation worked for me

1 Like

This worked! Thanks!

this Worked out for Me. Thanks.

This is worked for me too Thank you so much @ggray

Wanted to ask, from where you are downloading previous versions?, seems the only one available is, currently the 4.21.1.

@ggray legend!! tks for your help… One thing that i want to add is, the file can be rename with any word, I renamed my file to teste.json


It seems like you’re facing an issue with Docker after a remote update using TeamViewer. The error message you provided indicates an issue with parsing JSON during the installation process. This could be caused by various factors, such as corrupt installation files or conflicts with other software.

Here are some steps you can try to troubleshoot the problem:

  1. Clean Uninstall of Docker: Before attempting a reinstall, make sure Docker is completely uninstalled from your system. Use the official Docker uninstallation instructions for your operating system to ensure a thorough removal.
  2. Check Antivirus/Firewall: Sometimes, antivirus or firewall settings can interfere with the installation process. Temporarily disabling these security programs during the installation might help.
  3. Check Windows Updates: Ensure that your operating system is up-to-date with the latest Windows updates and patches.
  4. Check .NET Framework: Docker Desktop requires the .NET Framework to function correctly. Ensure that you have the necessary version of .NET Framework installed on your system.
  5. Try an Offline Installer: Instead of using the online installer, try downloading the offline installer from the official Docker website. Offline installers usually contain all the required files, reducing the risk of connectivity issues during the installation.
  6. Run Installer as Administrator: Right-click on the installer and choose “Run as Administrator” to ensure that the installation process has the necessary privileges.
  7. Check Event Viewer: Look into the Event Viewer in Windows for any additional error messages related to the Docker installation. Minecraft Lmhmod
  8. Try Compatibility Mode: Right-click on the installer, choose “Properties,” and try running the installer in compatibility mode for an older version of Windows.
  9. Check System Requirements: Verify that your system meets the minimum requirements for running Docker Desktop, including virtualization support.
  10. Check Docker Forums: If none of the above solutions work, check the Docker forums or GitHub repository for known issues or seek help from the Docker community.

Please note that troubleshooting complex issues like this can sometimes be time-consuming. If the problem persists after trying the above steps, you may want to consider reaching out to Docker support for further assistance.

Perfect, thank you so much - delete all the docker directorys in AppData and ProgramData and run the newest install file - works perfect!

1 Like

it worked for me Thank you so much

This happened to me as well. I found this solution. Give it a shot.

For Windows users. Step 1:Download and install Wise JetSearch. Step 2: Search this “\AppData\Roaming\Docker” on your wise JetSearch search bar. Step 3: Right-click on any file you see, then click open folder. Step 4: Look at your address bar on top and click Roaming. Your address bar should look like this: [1]: [Address to Docker files location][1] Step 5: Delete the Docker and Docker Desktop folders.

Then you are done. Try installing Docker again. Thank you for reading

Worked for me. Old settings file had some invalid json content. Renamed and started afresh with no issues.