Docker Community Forums

Share and learn in the Docker community.

Installing Docker 1.12 on Ubuntu

beta

(Ken Snyder) #1

I have an Ubuntu VM on my laptop and I’d like to install the Docker 1.12 engine on it. I’ve followed the directions here:

https://docs.docker.com/engine/installation/linux/ubuntulinux/

I initially tried with Trusty but then tried again with Xenial too, in both cases I never recieved any errors but when I used apt-get to install Docker it installed version 1.11.2, build b9f10c9 instead. :frowning:

Can anyone help me get this up to a 1.12 release?


(springme) #2

Docker 1.12 didnot release yet.so you only can install 1.12 RC4 now.but you have to change source.list to use Trusty testing (not main)

deb https://apt.dockerproject.org/repo ubuntu-trusty main
–>
deb https://apt.dockerproject.org/repo ubuntu-trusty testing


(Dvohra) #3

Were the following commands run?

sudo apt-get update
sudo apt-get install apt-transport-https ca-certificates

sudo apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D

Add to /etc/apt/sources.list.d/docker.list
deb https://apt.dockerproject.org/repo ubuntu-trusty main

sudo apt-get update

sudo apt-get purge lxc-docker

apt-cache policy docker-engine

To upgrade to new version:

apt-get upgrade


(Katopz) #4

I use experimental instead (judge from repos folder)
here’s modified script from Docker doc.

sudo echo "deb https://apt.dockerproject.org/repo ubuntu-trusty experimental" > /etc/apt/sources.list.d/docker.list

And here’s full blog post https://medium.com/@katopz/install-docker-1-12-on-ubuntu-451c17e2cf0d

hth


(Ken Snyder) #5

Ok that did the trick. A shame the Docker 1.12 installation instructions are still pointing to “main” though :slight_smile:


(Ken Snyder) #7

I tried switching main for testing and experimental and in both cases ran the following after updating the docker.list file:

sudo apt-get upgrade
sudo apt-get update
sudo apt-get install docker

Now I have noticed that if I run the sudo apt-cache policy docker-engine command, I get the following:

docker-engine:
Installed: 1.11.2-0~trusty
Candidate: 1.12.0~rc4-0~xenial
Version table:
1.12.0~rc4-0~xenial 0
500 https://apt.dockerproject.org/repo/ ubuntu-xenial/experimental amd64 Packages
1.12.0~rc3-0~xenial 0
500 https://apt.dockerproject.org/repo/ ubuntu-xenial/experimental amd64 Packages