Intermittent "i/o timeout" composing multiple services

I use docker-compose -f docker-compose.yml up

It should start 13 containers with different services. 4 out of 5 times I run it some of the services are “timed out” like

`
Starting docker-sandbox_redis_1 … done

Starting docker-sandbox_influxdb_1 … done
Starting docker-sandbox_grafana_1 … done
Starting docker-sandbox_telegraf_1 … done
Starting docker-sandbox_mongo_1 … done
Starting docker-sandbox_keycloak_1 … done
Starting docker-sandbox_pf-emulator_1 … done
Recreating docker-sandbox_sts-config_1 … done
Recreating docker-sandbox_sts-registration_1 … done
Recreating docker-sandbox_stsregistrationsvc-alb_1 … done
Recreating docker-sandbox_sts-runtime_1 … done
Recreating docker-sandbox_stsconfigsvc-alb_1 … done
Creating docker-sandbox_sts-authorization_1 … done
Recreating docker-sandbox_stsruntimesvc-alb_1 … error
ERROR: for docker-sandbox_stsruntimesvc-alb_1 b’i/o timeout’
ERROR: for stsruntimesvc-alb b’i/o timeout’ <------- ERROR
ERROR: Encountered errors while bringing up the project.
`
Earlier, when I had 10 services (3 less than now), timeout happened ~ 1 out of 5 runs. So most probably this relates to the overall computer load.

Unfortunately, message is very abrupt.
Please help understand an issue, I hope the timeout can be configurable somewhere.

Docker desktop 4.8.1 (tried 5 different versions),
Windows 11 (same problem on Win10),
WSL2 (tried docker w/o wsl and different Ubuntus)