Is it possible to change the Architecture Type of an Docker Image built on Docker Hub

Hi there,

I am crosscompiling / building Filesystems for Raspberry Pi / ARM on my local system and upload said filesystems to Github. As part of the automatic build, Docker Hub grabs those tar.gz files and just unpacks those into a “scratch” image. In earlier days, this worked perfectly (and still does) - however, as these images are “built” on Docker Hub, they are flagged as x64 arch. However, I just copy the ARM Filesystems into that image and starting them on a RPi worked - as long as the Manifest entry now introduced did not prevent that… Is there any way to manipulate the architecture entry of an on Docker Hub built image - or if locally built on a x64 Linux System?

Thanks a lot!


I’ve found the same problem. I can do it if I manually build with qemu. But was looking at automated builds from github, and on the first time it tries to run something in the build it fails with a format error as it’s amd64 not arm