Issue building docker image with bash: 403 Forbidden error for loading metadata

When I try to build a docker image, I get a 403 forbidden error as such:

ERROR: failed to solve: failed to resolve source metadata for [redacted].registry.jetbrains.space/p/main/[repo name]/buildbase:latest: failed to authorize: failed to fetch anonymous token: unexpected status from GET request to https://[redacted].registry.jetbrains.space/oauth/token?scope=repo[…]: 403 forbidden

I am very new to docker and unsure why some of my images from a Jetbrains Space repo are building properly but not others, is there anything I can do to help resolve this 403 Forbidden error?

I have tried restarting, tried running the bash script many different times, tried logging in/out of Jetbrains Space to see if that would help, but I can’t really seem to pinpoint the issue. I am completely new to Docker/Jetbrains so I am really at a loss.

I had a similar problem today fetching the token for my first build. It worked after I verified my email address using the link in the email from Docker. My first day at Docker :slight_smile:

Your path is different to mine. I was fetching from the docker.io, so my solution might not work for you…

Good luck