Issue installing Docker desktop on Windows 11

Trying to install Docker Desktop on Windows 11 machine. Have tried both default WSL and Hyper-V but I get the following error whenever running the installer.

Component Docker.Installer.CreateGroupAction failed: Could not load file or assembly ‘System.DirectoryServices.AccountManagement, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’ or one of its dependencies. The module was expected to contain an assembly manifest.
at Docker.Installer.InstallWorkflow.d__30.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Docker.Installer.InstallWorkflow.d__23.MoveNext()

Any ideas what may be the issue.

I have confirmed that the prerequisites are installed.
Have tried running the installer as admin also.

Issue fixed.

Was caused by corrupted dll in GAC_MSIL\System.DirectoryServices.AccountManagement\v4.0_4.0.0.0__b77a5c561934e089