Docker Community Forums

Share and learn in the Docker community.

Issue updating docker package lists for apt.dockerproject.org on Ubuntu Trusty


(Ortizmj12) #1

I updated my repository according to the “NEW APT AND YUM REPOS” blog post when the blog came out. Everything went smooth. It’s been a couple weeks since I’ve booted up this VM and now I’m having issues updating the package list for apt.dockerproject.org. I get the following errors when I run “sudo apt-get update”:

W: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-trusty/main/binary-amd64/Packages server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-trusty/main/binary-i386/Packages server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

I noticed that the SSL cert for apt.dockerproject.org was updated recently - the valid starting date says Aug 10, 2015. Could this be related? I’ve tried “update-ca-certificates”, but that doesn’t fix the issue. Even reinstalled the “update-ca-certificates” package juuust to be sure, but nope.

Halp? :slight_smile:


(Ortizmj12) #2

And now I don’t see the problem this morning, sweet! But I’m curious what might’ve been going on. Anybody have any insight here?


(Kevin O'Neill) #3

Still having this same problem…when trying to install 1.8.1:

sudo curl -sSL https://get.docker.com/ | sh
apparmor is enabled in the kernel and apparmor utils were already installed
+ sudo -E sh -c apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.RBmWG4yZBP --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
gpg: requesting key 2C52609D from hkp server p80.pool.sks-keyservers.net
gpg: key 2C52609D: "Docker Release Tool (releasedocker) <docker@docker.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
+ sudo -E sh -c mkdir -p /etc/apt/sources.list.d
+ sudo -E sh -c echo deb https://apt.dockerproject.org/repo ubuntu-trusty main > /etc/apt/sources.list.d/docker.list
+ sudo -E sh -c sleep 3; apt-get update; apt-get install -y -q docker-engine
Ign http://dl.google.com stable InRelease
Ign http://us.archive.ubuntu.com trusty InRelease
--snip-snip-snip--
Hit http://us.archive.ubuntu.com trusty-backports/main amd64 Packages
Err https://apt.dockerproject.org ubuntu-trusty/main amd64 Packages
    server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Hit http://us.archive.ubuntu.com trusty-backports/restricted amd64 Packages
Hit http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages
Err https://apt.dockerproject.org ubuntu-trusty/main i386 Packages
    server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Hit http://us.archive.ubuntu.com trusty-backports/multiverse amd64 Packages
--snip-snip-snip--
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
W: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-trusty/main/binary-amd64/Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-trusty/main/binary-i386/Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package docker-engine

Any suggestions on how to deal with this would be most helpful!!!
Thanks!


(Peng Peng Wang) #4

I have such problem. But have no idea about the workaround…:confounded: