Docker Community Forums

Share and learn in the Docker community.

Issue with 'docker build' on rhel 7.4 - complete beginner issue I'm sure


(Davidjcopenhaver) #1

Hello,

New to Docker and this site so apologies if this is not the right forum…

I have docker up and running on a RHEL 7.4 host system, trial version of Docker EE.

Dockerfile with literally two lines:
FROM busybox
RUN [“mkdir”, “/mydirectory”]

“docker build .” command results in this error:
standard_init_linux.go:187: exec user process caused "permission denied"
The command ‘mkdir /mydirectory’ returned a non-zero code: 1

SELinux is completely disabled so it’s not that, which I have seen while googling this…

Any ideas? I also tried using the ‘shell’ format of RUN but same error. If I use CMD there is no error but it also does not create the directory.

Regards


(Davidjcopenhaver) #2

not sure why but deleted the image from local storage, did a new pull/run of busybox to redownload the image and validate it runs - then my custom build just worked, no changes…

¯_(ツ)_/¯