Docker Community Forums

Share and learn in the Docker community.

Issue with official kiwix-serve

hi,
i m new here so don t hesitate to modify topic tags if wrong

i have an issue with docker-compose and docker hub kiwix-serve official image that i already tried to solve on github with the developper
i join this link for more details


to sum up
1/ when i launch kiwix-serve image with docker run, the container keeps running until i shut it down
2/ when i launch kiwix-serve image with docker-compose, the container launch and stop immediately i wonder if no more process is running

i also tried to replace the script start.sh a custom start.sh in the /usr/local/bin including the --daemon switch to keep it running in background, no more effect

as you can read, someone answered me the problem comes from docker-compose, but i wonder about the given answer and i want to know if someone succeeded in daemonize the kiwix-serve application
-> docker compose will allow automatic boot without adding script, so it could more clean

thx in advance