Jellyfin Port No Longer Open

I have had a Jellyfin container running for several months now with no issues. I use port 8096 to access it. I recently tried to get a reverse proxy running using an nginx container. I was not having any success with the reverse proxy but in the process I am no longer able to access Jellyfin. I even went as far as to remove the Jellyfin container and create a new one but still no luck. I have several other containers running and I am able to connect to the with no issue. I use portainer to manage my containers. The details for my system are as follows:

Openmediavault version - 6.7.0-3 (Shaitan)
Docker version 24.0.5, build ced0996
*OS Linux 6.1.0-0.deb11.7-amd64 *
Portainer server version 2.16.2
Portainer database version 72

I have used nmap to see what ports are open on my system, here’s the output:

Starting Nmap 7.80 ( ) at 2023-09-01 15:56 EDT
Nmap scan report for mcp (
Host is up (0.0000060s latency).
Not shown: 988 closed ports
22/tcp open ssh
80/tcp open http
111/tcp open rpcbind
139/tcp open netbios-ssn
443/tcp open https
445/tcp open microsoft-ds
2049/tcp open nfs
5357/tcp open wsdapi
6881/tcp filtered bittorrent-tracker
8000/tcp filtered http-alt
8080/tcp filtered http-proxy
9000/tcp filtered cslistener

Nmap done: 1 IP address (1 host up) scanned in 1.30 seconds

Is there a way to open this port or is there something deeper I am missing. I have tried to look at different config files for docker but I am unable to find one that seems like is blocking the port. Let me know what further information is required. Thank you.

What are your settings for the Jellyfin container?