Docker Community Forums

Share and learn in the Docker community.

Killing off a failed image pull request


On one of my docker hosts (Ubuntu 18.04), in syslog i keep seeing this show up every 2 seconds. I have no idea how to stop it. I have restarted the host many times - still happens. I dont need this image pulled down - i guess when i was first doing my first local registry, i didnt put in the image name.

Jul 21 03:46:02 docker01 dockerd[1000]: time="2019-07-21T03:46:02.483095785Z" level=error msg="Not continuing with pull after error: errors:\ndenied: requested access to the resource is denied\nunauthorized: authenJul 21 03:46:02 docker01 dockerd[1000]: time="2019-07-21T03:46:02.483956994Z" level=info msg="Ignoring extra error returned from registry: unauthorized: authentication required"

Jul 21 03:46:02 docker01 dockerd[1000]: time="2019-07-21T03:46:02.484242857Z" level=error msg="pulling image failed" error="pull access denied for st-0000-demo_rca, repository does not exist or may require 'docker Jul 21 03:46:02 docker01 dockerd[1000]: time="2019-07-21T03:46:02.485864858Z" level=error msg="fatal task error" error="No such image: st-0000-demo_rca:latest" module=node/agent/taskmanager

I cant find anywhere how to kill off a request - other then rebooting, which i have done many many many times for other reasons already.


This should only happen if a Swarm service is used.

If created from a stack: correct your compose.yml. remove the stack and deploy it again.
If started as a service: remove the faulty service and re-create it using the correct registy/repo:tag

Also don’t forget to performa a docker login on the master node you use to deploy the stack/service. Start your stack with docker stack deploy --with-registry-auth ... or start your service with docker service create --with-registry-auth ... to make sure the repo credentials are forwarded to the other nodes.

I an 99% sure it would of happened when i did adocker deploy --compose-file XXXXX. But i am not using that stack - as i have since done that part properly. docker-compose.yml is correct, and now reading the correct image, but it still happens -

How do i kill it off?

Like i wrote: you have to remove the service that makes Docker pull the image.

I had the situation a couple of times and this always fixed it for me.