Docker Community Forums

Share and learn in the Docker community.

Kitematic MySQL on Windows 10 Home

I just burned a night struggling to get the standard mysql:latest with Kitematic on a Windows 10 Home laptop up and functional.

I was able to install the Docker Toolbox. And, Kitematic seems to work great. It pulls containers and starts and just works awesome.

I pulled mysql:latest, added a MYSQL_ROOT_PASSWORD environment variable under the Settings tab (took me a little time to find that…), and sparked it right up.

I can even open the Kitematic EXEC window and run mysql.

I created a new user and granted God permission to * . *. Again, everything just worked. Yay!

Kitematic shows that it is mapping Docker Port 3306/tcp to 192.168.99.100:32777. And from my windows cmd.exe I can ping the stuffing out of 192.168.99.100.

But, for the life of me I can’t figure out how to connect to the running mysql server from outside Kitematic.

I’ve tried just about everything, but a fairly plain vanilla example is with MySQL Workbench (v6.3.8 build 1228 CE 32 bit).

I click on Setup New Connection. I enter 192.168.99.100 as hostname, and 32777 as the port. It fails with a root login and also with the new user I created.

When I click the Test Connection button, I get “Failed to Connect to MySQL at 192.168.99.100:32777 with user root”; “Can’t connect to MySQL server on ‘192.168.99.100’ (10061)”

Can anyone help me connect to the server from Windows? What am I missing?

1 Like

Is your problem solved? What method was used to solve the problem?

No. U went with a different solution. If you are having trouble with this, I might try again this weekend. Let me know.