Docker Community Forums

Share and learn in the Docker community.

Lancachenet/monolithic Local DNS Issue with Ubuntu 18.04

I have set up lancachenet/monolithic on Ubuntu Server 18.04 using the following script (derived from example instructions):

docker run --restart unless-stopped --name lancache-dns --detach \
  -p 192.168.0.151:53:53/udp \
  -p 172.17.0.1:53:53/udp \
  -e USE_GENERIC_CACHE=true -e LANCACHE_IP="192.168.0.151 172.17.0.1" lancachenet/lancache-dns:latest
docker run \
  --restart unless-stopped \
  --name lancache \
  --detach \
  -v /cache/data:/data/cache \
  -v /cache/logs:/data/logs \
  -e UPSTREAM_DNS="1.1.1.1 1.0.0.1" \
  -e CACHE_MEM_SIZE=4000m \
  -e CACHE_DISK_SIZE=1t \
  -p 192.168.0.151:80:80 \
  -p 172.17.0.1:80:80 \
  lancachenet/monolithic:latest
docker run --restart unless-stopped --name sniproxy --detach \
  -p 192.168.0.151:443:443 \
  -p 172.17.0.1:443:443 \
  lancachenet/sniproxy:latest

With default Ubuntu Server, this will fail because systemd-resolved is already listening on port 53. Long story short, I disabled Systemd-Resolved and got the lan-cache running as a replacement

But the lancachenet/monolithic container is immediately and continuously restarting each time it sort-of starts. I notice it is trying to listen on port 443. So is the sniproxy. The sniproxy needs to, and the lancache needs not to. I wonder if the lancache is failing to start because it can’t get the port it mistakenly thinks it needs?

For a brief second every 60 seconds, I can gather this info:

CONTAINER ID        IMAGE                             COMMAND                  CREATED              STATUS              PORTS                                                      NAMES
f106a1f66b87        lancachenet/sniproxy:latest       "/scripts/bootstrap.…"   34 seconds ago       Up 32 seconds       172.17.0.1:443->443/tcp, 192.168.0.151:443->443/tcp        sniproxy
e193af15121e        lancachenet/monolithic:latest     "/bin/bash -e /init/…"   44 seconds ago       Up 1 second         172.17.0.1:80->80/tcp, 192.168.0.151:80->80/tcp, 443/tcp   lancache
faa271c246dc        lancachenet/lancache-dns:latest   "/bin/bash -e /init/…"   About a minute ago   Up About a minute   172.17.0.1:53->53/udp, 192.168.0.151:53->53/udp            lancache-dns

Any thoughts or help on any of this would be much appreciated.
Thanks.