Lost Network Connection After Docker Install - Fresh Debian Install

Real noob here so bear with me lol. I’ve been using portainer to configure containers for a while on a Raspberry Pi using DietPi, so the initial set-up for me in the past has been a lot more simplly pre-configured. My Pi decided to throw in the towel the other day so I picked up an older ThinkCentre M700 to use instead and installed plain old Debian 12 on it.

Clean install, all I’ve setup so far is Docker and Portainer, but the moment they were installed I lost all network connection on the host device. I can access Portainer using the Web UI but have no connectivity here either. I’m not sure what I’m missing or where to start.

“connect: no route to host” error is usually what I get within Portainer. Pinging DNS or website on the host device results in unreachable.

If I use pkill docker then network returns on the host.

Tried the following:

sudo apt-get install bridge-utils
sudo apt-get install net-tools
sudo pkill docker
sudo iptables -t nat -F
sudo ifconfig docker0 down
sudo brctl delbr docker0
sudo docker -d
sudo service docker restart

Both docker/portainer and host will function correctly for about 30 seconds before losing connection again if docker service is restarted.

EDIT: Fixed.

Weirdly not sure how this happened or helped exactly but i installed NetworkManager which wasn’t installed by default for whatever reason, but after that I kept getting random GUI crashes (also didnt fix the issue) which prompted me to remove lxqt DE and install fxce4, updated and then used sudo apt autoremove reboot and it seems to be running perfectly. :person_shrugging:

i have the same issue
When i run a docker build or a docker run after 20s or 30s all connection to the internet is cut