Docker Community Forums

Share and learn in the Docker community.

Macvlan no ping possible but arp works (outgoing only)

First of all to my setup. I run on Hyper-v an Docker installation on Debian 11.
The Debian has 2 network interfaces:
eth0: For Management Debian + Portainer (192.168.20.99)
eth1: should be a vlan trunk; for the running containers (For testing now only VLAN 178)

For testing I have now a W10 VM in Hyper-V with one interface (192.168.178.50; VLAN 178).

Both interfaces (W10 and the following macvlan configuration are in VLAN 178)

Now I configured exactly the following (only with VLAN 178): Connecting the Docker container to the external network via VLAN Tag - designetwork(EN)

[Bild 2]
[Bild2.1]

As Container for testing I used: (Container with IP 192.168.178.201)
[Bild 3]

Now I want to ping between the Docker Container and the W10 VM. But this is not worling, in both directions not.
But as I ping from the Container to W10 VM the arp packets are arriving and the W10 is answering. But in the Container the arp answeres are not arriving. So where is here the problem? Why are arp packets do not reach the Container???

[Bild 4]

[Bild 2]

[Bild 3]

[Bild 4]

[Bild2.1]

I didn’t have much time to think about your issue but I want to reply because I had a similar problem between a host machine and an LXD virtual machine just yesterday. I had to come to the conclusion that it was not a bug. We can’t ping the host from the VM (container in your case) or ping the VM from the host in case of MacVLAN.

I can’t find twhat I have read about this before, but this is a similar answer related to Docker:

It seems this is how macvlan works.

Thanks for the replay. Something like this I also red before. But how is it than possible to use a VLAN trunk with docker and put a container is a specific VLAN (as a normal device in the network)?

I can only create a interface in Hyper-V for each vlan and then use a bride network per vlan with only one IP per Interface? But than the container does not have specific IP right?

I againt tried the following steps: Docker Networking: macvlans with VLANs – HiCube

But there the same problem. It does not work. But why?
In all these instrutctions it seems to work without problems.

I have the same issue, and it is driving me nuts. Have spend hours and hours trying to figure out what the problem is but can’t put my finger on it. Any help by anybody would be appreciated!!

1 Like