Docker Community Forums

Share and learn in the Docker community.

Mapping failed since last update


(Loulouklm) #1

Expected behavior

Loading nginx container with a volume. It worked before last update on this morning.

Actual behavior

When nginx container start I got this error
[crit] 1#0: pread() “/etc/nginx/sites-enabled/cineweb.conf” failed (21: Is a directory)

volume is
- ./docker/conf/cineweb.conf:/etc/nginx/sites-enabled/cineweb.conf

File is here and it worked before.
It is on my D: drive. It is checked in Shared drives.

I try to uninstall docker and install it again. Nothing goes well.

Information

  • the output of:
    • Moby Notification > Diagose & Feedback on Windows
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

Steps to reproduce the behavior


(Loulouklm) #2

Find myself a solution. Ouf I was going crazy.
I juste share C drive in setting panel that wasn’t. It asks me to give my credentials. And that it!

I think C drive share is not important but just to put again my credentials solve this issue. Not sure. I will try to unshare C drive and let you know if it still running well.


(Jean-Laurent de Morlhon) #3

Thank you for your feedback

Does it work with a full path and without the C drive mounted ?

something along the lines of :

- d:/foo/bar/docker/conf/cineweb.conf:/etc/nginx/sites-enabled/cineweb.conf


(Loulouklm) #4

I tried it before I found a solution but it didn’t work.
Are you sure about syntaxe? I guess it would be:

  • /d/foo/bar/docker/conf/cineweb.conf:/etc/nginx/sites-enabled/cineweb.conf