Docker Community Forums

Share and learn in the Docker community.

Missing network interface in docker container


(Sdsi) #1

I have been playing with docker successfully for a few weeks now but have just recently run into a rather peculiar problem: my docker containers have no network interfaces, and there is also no /etc/network/interfaces file. I am not able to get any network action at all. However the ip command does exist and the command: ip a responds with:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
9: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
link/ether 02:42:ac:11:00:02 brd ff:ff:ff:ff:ff:ff
inet 172.17.0.2/16 scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::42:acff:fe11:2/64 scope link
valid_lft forever preferred_lft forever

I recently tightened up the iptables policy rules to drop all but specified services, and thought this might be the source of the problem, so I added DOCKER_OPTS="–iptables=false" to /etc/default/docker and restarted docker, but the problem persists.

I have tried this using newly pulled debian, ubuntu and fedora images, starting the container with: docker run -it /bin/bash, and always with the same result.

I am using docker version: 1.9.1 and any help would be greatly appreciated. If I can provide any further details or information, please let me know.

Thanks,

Daryl Williams