Docker Community Forums

Share and learn in the Docker community.

Missing options in the Settings menu

I am running Docker 18.06. My Settings menu is showing only 4 options: General, Proxies, Daemon and Reset. I saw images of the Settings menu online and are there more options which are not showing for me like Shared Drives and Advanced.

Why am I not seeing the rest of the options?

3 Likes

I have the same question

1 Like

Same question. Docker for Windows docs appear to be way out of date.

1 Like

You have to use Linux type container to see these options. Lots of documentations mention Docker and it seems they are assuming you’re using Linux type of container. It’s confusing for beginners.

3 Likes

I have the same issue. But when I switch to Linux containers, Docker restarts and I get the error dialog:

Unable to start: The running command stopped because the preference variable “ErrorActionPreference” or common parameter is set to Stop: ‘MobyLinuxVM’ failed to start. (Virtual machine ID E09206B4-5FBB-427E-957C-498BDDCD5BCA)

‘MobyLinuxVM’ failed to start worker process: %%3228369022 (0xC06D007E). (Virtual machine ID E09206B4-5FBB-427E-957C-498BDDCD5BCA)
at Start-MobyLinuxVM, : line 300
at , : line 395
at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object[] parameters) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Core\pipe\NamedPipeClient.cs:line 36
at Docker.Actions.<>c__DisplayClass25_0.b__0() in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Windows\Actions.cs:line 275
at Docker.WPF.TaskQueue.<>c__DisplayClass19_0.<.ctor>b__1() in…

Any guidance is very much appreciated!

OK. So switching to Linux containers and playing with the “Resources > Advanced” only modifies the VM for running Linux containers and not Windows containers. To adjust the amount of memory for Windows containers you need to use the --memory flag when you run the windows image. For example:

docker run --name myWinImage --memory 4096m --cpus 2 -it -p ‘4096:7880’ --entrypoint powershell

I was missing the “m” in “4096m”.

This article help me figure it out: https://www.sqlservercentral.com/blogs/default-resource-limits-for-windows-vs-linux-containers-in-docker-desktop

1 Like

I am having same issue right now. Is it because i am using free version of docker desktop for now?

Not sure. Help if anybody got this one fixed!

In my case I was using linux containers, but wsl2 based engine option was enable so, I was not able to see advanced option.

So I disabled WSL 2 integration and it appeared again.

References: