Docker Community Forums

Share and learn in the Docker community.

MSSQL Container Exits Immediately

Hello,

I tried to install mssql container on both docker desktop and kitematic but I’m getting below error. When I want to run container it exited immediately.

Thanks for your helps.

`This program has encountered a fatal error and cannot continue running.
The following diagnostic information is available:
Reason: 0x00000003
Message: result == 0
Stacktrace: 00000040000573fe 0000004000056f90 0000004000036d81
00000040000377af 000000400004cc51 00000040000295df
000000400490d830 00000040000269a9
Process: 10 - sqlservr
Thread: 10
Instance Id: b5e2d0eb-c8f7-49c5-a16b-f9bc9dd4c086
Crash Id: c02c42ee-6716-4072-904c-d1c475fd54e1
Build stamp: 7d599fe53e35b5a1b0c8a5e4185d8b7334e01a8c5fa77540415502a85f37ef27
Capturing core dump and information…
dmesg: read kernel buffer failed: Operation not permitted
No journal files were found.
No journal files were found.
Attempting to capture a dump with paldumper
WARNING: Capture attempt failure detected
Attempting to capture a filtered dump with paldumper
WARNING: Attempt to capture dump failed. Reference /var/opt/mssql/log/core.sqlservr.10.temp/log/paldumper-debug.log for details
Attempting to capture a dump with gdb``

I have MacBook pro (13-inch, M1,2020) and the same issue. Did you get solved this issue?