Multiple RDPs using different VPNs through docker containers

Hello everybody,
I’m used to work with multiple RDPs eachone using a different VPN connection.
The VPN provider can be different as well, the main ones are Forticlient 7, OpenVPN GUI, NetExtended, Wathcguard Mobile VPN.
I was looking for something that can hep me to connect to multiple VPNs at the same time and connect to multiple RDP as well.
I found out two images in docker hub that could feet very well my need:

The only problem is the version of forticlient and netextender used in these packages.
I’ve tried to download the new version of ubuntu image and tried to install the latest fortclient version, but I’m not an expert in linux and I am not able to achive my goal.
Anyone can help me to create an image that contains all VPN software and help me to create something very similar to the jakubv images with the additional parameter of the VPN software to be used?

I think that this kind of image will be very useful for people like me that use multiple VPN every day.

Thanks very much

Anybody can help me or interested in this topic?

It is not impossible, but It is not likely that you will find someone to volunteer to create an image, but if you can share what you tried and how it failed, you may find someone who can give you some advice what you should do differently.

Or you can also try to find other Docker images like this:

Seems good and workinf at least for connecting to VPN.
But I don’t understand how to configure everything to work with RDP.
I’ve tried to create a network as explained in github and tried to add ip route (on windows):
“route add [destination.rdp.pc.ip] MASK”
and then tried to connect with RDP to [destination.rdp.pc.ip] but it’s not working. Can you help me to understand why and how to do that?

Thanks in advance

I’ve tried this:

  1. run the container:
    docker run -it -P --device /dev/net/tun:/dev/net/tun --device /dev/ppp:/dev/ppp --cap-add NET_ADMIN -e VPN_ADDR=[address_ip]:[port] -e VPN_USER=[usr] -e VPN_PASS=[psw] poyaz/forticlient:latest
    (repleacing [ ] field)
  2. get the container ip:
    docker inspect --format ‘{{ .NetworkSettings.IPAddress }}’ 17681b21dce94baa6ae3300308c113e95d6eb3131b
    and got
  3. add routing:
    route ADD [RDP_Machine_ip] MASK
  4. tried to connect with RDP to the machine [RDP_Machine_ip]

what’s wrong with that?

I’ve also tried to use docker-compose and added port 3389

version: “2.3”

I will appreciate a lot your help

Does ping work? I haven’t used this image yet, so I don’t think I could help you a lot for now. Make sure you can access the IP to which you want to route traffic and use tracert or tracepath to trace the traffic. tcpdump and tshark can help too.

No the ping is not working,I don’t understand why