Docker Community Forums

Share and learn in the Docker community.

Need to specify proxy settings

could u put the totally command here??

i am a new docker while i run the tutorial from docker document,

it can’t run

i guess network is blocked by our government…

i need to set the proxy, to proxy the network connect to my vpn(vultr)…

Is there a timeframe for when Docker will get basic NTLM proxy support for Windows (use the logged in windows user’s credential).

1 Like

And here it is January 2020… and it seems like this still isn’t fixed.
OS: OSX - Mojave 10.14.6
Docker Desktop: v2.0.03 (31259)
Docker version 18.09.2, build 6247962

Here’s the use case I’m in… we have a private docker registry that the client uses. In order to access it, I tunnel in using VPN. When that happens, my system preferences are updated to use my local system 127.0.0.1 as the proxy server. What I’m trying to do now is a simple docker image pull from that repo. It. Does. Not. Work. Despite my settings to use system proxy, it just won’t go. I get the “proxy requires authentication” error. But no where is there a place to enter the info. I’m not interested into relaying the proxy settings to the container, heck all i’m trying to do at this point is just pull the infernal thing. I can’t turn the tunnel off, because then I wouldn’t be on the network it’s on. Everything works fine if I pull an image from a public registry, but that’s just not going to work for us.

So, what do I do? I’ve tried putting http_proxy settings all over the place, different files and such. What lead to this is that I’m trying to pull an image that has a copy of our development database in it so that it can be included in our project maven POM file. then when a future developer needs the database they can use a mvn install -Dbuild-db to get the image and spin it up. Nothing fancy. No need to pass the proxy to the running container. Again, at the moment I can’t even do a simple docker image pull command with out this going sideways. It simply. Will. Not. Work.

I am running docker desktop 2.2.0.3 with docker engine 19.03.5 and proxy setting did not work for me at all. i have set

~/.docker/config.json … did not work
env variables … did not work

and then I looked at the preferences that are behind the whale symbol, there they are, proxy settings. I searched forever an could not find any help on this, but maybe I need to get certified googling skills, who knows.

These proxies setting actually work, If you want to use socks5, try using privoxy as backend proxy.