Docker Community Forums

Share and learn in the Docker community.

Mac beta17 ignores no_proxy setting


(Cjoy) #1

Action

docker pull docker.company-network.corp:50123/com-company-docker/imagename

Expected behavior

Connect to private docker registry directly, without resolving address via proxy.

Actual behavior

Error response from daemon: Get https://docker.company-network.corp:50000/v1/_ping: http: error connecting to proxy http://proxy:8123: dial tcp: lookup proxy on 192.168.97.1:53: no such host

Information

OS X 10.11.6
Docker Version 1.12.0-rc2-beta17 (build: 9779)
ff18c0c63c5ff3c4a4a925d191d5592d655779d7

proxy settings (network preferences > advanced > proxies):
http_proxy: http://proxy:8123
https_proxy: http://proxy:8123
no_proxy: *.company-network.corp

settings are reflected in kitematic.


(Cjoy) #2

Turns out the beta was not updating properly. After uninstalling the the docker for mac beta and docker-machine, then reinstalling from the latest dmg, everything is cake. Works as expected.