--net=host not working on Arch Linux

So, I am quite new to docker and have tried to install a few containers on a newly created physical server running Arch Linux with the LTS kernel (4.9.27).
Fx. the official plex container image does not work. If I set --net=host, then it does not connect with my account and I can also not find it anywhere on the network. If I set it to --net=bridge, then I can access Plex using the defined ports on my host machine.

So far that I have understood --net=host makes it so that my container is getting an IP-address on the local network, so that I do not have to open a lot of ports on the host machine.

This is the output of docker info with the plex container running:

Containers: 1
 Running: 1
 Paused: 0
 Stopped: 0
Images: 1
Server Version: 17.05.0-ce
Storage Driver: zfs
 Zpool: tank
 Zpool Health: ONLINE
 Parent Dataset: tank/storage/docker
 Space Used By Parent: 307985744
 Space Available: 653827862160
 Parent Quota: no
 Compression: lz4
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 9048e5e50717ea4497b757314bad98ea3763c145
runc version: 9c2d8d184e5da67c95d601382adf14862e4f2228
init version: 949e6fa
Security Options:
  Profile: default
Kernel Version: 4.9.27-1-lts
Operating System: Arch Linux
OSType: linux
Architecture: x86_64
CPUs: 16
Total Memory: 15.66GiB
Name: behemoth.khit.local
Docker Root Dir: /mnt/tank/storage/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false

Running ip a gives this output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc mq state UP group default qlen 1000
    link/ether a4:ba:db:41:56:f7 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80::a6ba:dbff:fe41:56f7/64 scope link 
       valid_lft forever preferred_lft forever
6: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:2f:f0:8b:2a brd ff:ff:ff:ff:ff:ff
    inet scope global docker0
       valid_lft forever preferred_lft forever

I have removed anything apart from the loopback interface, the primary interface and the docker0 interface.

Can someone tell me what I am missing in order to get the containers running with --net=host?