Docker Community Forums

Share and learn in the Docker community.

New container when I restart

Hi folks,
My apologies for the noob question but I cant seem to find an answer. I was handed an Ubuntu server (v16.04) running Docker v18.09.6. This is running 7 containers, 5 dev tool apps, postgress sql and traefik. The server is hosted in Azure and the containers are stored in an Azure storage account. I made the mistake of rebooting the server… I am not a Unix/Linux person and Docker is new to me so this is probably just beginner problems but when I eventually managed to get the Azure file share mounted again and my containers reappeared I thought that was the end of my issues however 2 apps are being rather difficult. Confluence, this managed to sort itself out eventually and Artifactory, this is still down, looks like a tomcat problem perhaps. But my question is when I stop and then start the container I get a new container every time so as a result when I run “docker ps” I see 7 running but when I run “docker ps -a” I see 16, multiple Confluence and Artifactory containers that aren’t running. Is this normal? If not what could be causing it? And can I safely delete them? Example below of 2 Artifactory containers. Any advice would be greatly appreciated.

IMAGE COMMAND CREATED STATUS PORTS NAMES
1f1c552443ce docker.bintray.io/jfrog/artifactory-pro:latest “/entrypoint-artifac…” About an hour ago Up About an hour 8081/tcp tools_artifactory.1.
17fc49d5a65b docker.bintray.io/jfrog/artifactory-pro:latest “/entrypoint-artifac…” 17 hours ago Exited (0) About an hour ago tools_artifactory.1.

If you share how you start your containers, someone might actualy be able to help! Systemd, docker run, docker compose, swarm stack, … ? The exact commands please. The behavior can be prevented and not normal if done right - except for swarm, which will always schedule a new task, which will create a new container.

Hi, thanks for the reply. I managed to snag some time with the consultant who built the system and this is happening by design. I was able to delete the older containers as well. So consider this thread closed. Thanks again.