No docker compose v2 on MacOS 13.0.1


I just installed Docker Desktop on my new Macbook, but suprisingly it doesn’t contain Docker compose:

Docker-compose (v1) does work, but when I check the “Use Docker Compose V2” setting, I get the same error. Is this a know issue and/or is there a workaround to start using docker compose v2?

MacOS version: 13.0.1 (Ventura)
Docker desktop version: 4.14.0
Compose version (according to Docker desktop): 1.29.2


Please, share the output of

docker version


ls -l $HOME/.docker/cli-plugins

I have the same versions, but I realized I acidentally overwrote the cli plugins so they are symbolic links to different plugins. I have to fix this, so I will reinstall my Docker Desktop, but not right now.


I removed Rancher Desktop which added the links to the CLI plugin, but I still have Docker Compose, so please share the output of the folloving command too:

ls -l /usr/local/bin/docker-*

Thank you for your reply.

docker version output:

 Cloud integration: v1.0.29
 Version:           20.10.21
 API version:       1.41
 Go version:        go1.18.7
 Git commit:        baeda1f
 Built:             Tue Oct 25 18:01:18 2022
 OS/Arch:           darwin/arm64
 Context:           default
 Experimental:      true

Server: Docker Desktop 4.14.0 (91374)
  Version:          20.10.21
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.18.7
  Git commit:       3056208
  Built:            Tue Oct 25 17:59:41 2022
  OS/Arch:          linux/arm64
  Experimental:     false
  Version:          1.6.9
  GitCommit:        1c90a442489720eec95342e1789ee8a5e1b9536f
  Version:          1.1.4
  GitCommit:        v1.1.4-0-g5fd4c4d
  Version:          0.19.0
  GitCommit:        de40ad0

LS on the cli-plugins directory says that the directory does not exist:

Output of the ls on docker-*:

In the meantime, I relized, that will not show Docker Compose v2, only if you enabled “Use Docker Compose v2”, which you tried, but that is not the docker compose plugin, and currently I am not sure where mine is.

Could you try to enable “Use Docker Compose v2” again and then run the folowing command?

docker-compose version

It is important to use docker-compose instead of docker compose this time.


I think I have found it:

ls -l /usr/local/lib/docker/cli-plugins/docker-*

Both docker-compose and docker compose give this output (when I check said checkbox).

ls -l /usr/local/lib/docker/cli-plugins/docker-* gives nothing back since I don’t have that directory.

Okay. I am going to remove everything now and see what happens when I reinstall Docker Desktop

1 Like

I have reinstalled Docker. It took more time, since I acidentally installed the intel version three times on my mac with M1 :smiley:

I still have Docker Compose v2. Now i am wondering, how did you install Docker Desktop on your mac?

I have a video about installing it: Install Docker Desktop for Mac like a pro in 14 minutes - YouTube

And I also have an other video about uninstalling it properly when something goes wrong with the installation: Uninstalling Docker Desktop properly on macOS - YouTube

The version of Docker Desktop was different in the video, but the method is the same and I used it again.

Can you try to Uninstall it completely and install it again?

I installed Docker via this link: Install on Mac | Docker Documentation (Mac with Apple silicon).
I installed rosetta, since that was recommended (both with and without gives the same result though).
And I must say, my colleague has the same issue, so it doesn’t seem to be a problem of my laptop specifically.

I just uninstalled completely (through Docker desktop troubleshooting) and reinstalled: still the same result.

That will not remove everything. It claims to do that, but some files can still remain on Mac and it can’t remove the application itself from the Application directory. That is why I linked my videos.

I don’t know what other questions I could ask. Every time I move to the Application folder, it creates the cli plugins.

You could search for similar issues on GitHub or open a new issue if you don’t find any:

Thanks for your help though! And for linking that repository.
Turns out more people are ahving the same issue (docker-compose docker: 'compose' is not a docker command · Issue #6569 · docker/for-mac · GitHub). I’ll continue to follow that thread.


mkdir -p /usr/local/lib/docker
ln -s /Applications/ /usr/local/lib/docker/cli-plugins

These commands were the fix. :slight_smile:

1 Like