Docker Community Forums

Share and learn in the Docker community.

No such file or directory when using "docker-compose up" on the solution

docker

(Mirind4) #1

Hey all. I am having an issue relating docker-compose.
I would like to “docker-compose up” the solution but having a “No such file or directory” error

Expected behavior

The solution starts running

Actual behavior

Error message: bash: /bin-mount/wait: No such file or directory

Information

I tried to look for solutions for my issue. Most of them say that the line endings of my scripts should be converted to Unix. I have done that.

What I also tried is to remove “#!/bin/bash” from the beginning of my scripts, but did not solve my issue.

I am using “Docker Quickstart Terminal” on windows since I have only the Windows Home edition

My wait script file looks like the following:

#!/bin/bash
file=$1
while [ ! -f $file ] ;
do
      sleep 0.1
done

And a part of the docker-compose.yml

  generate-raw-addresses:
    image: techbureau/catapult-tools:gcc-0.1.0.2
    command: bash -c "/bin-mount/generate-raw-addresses-if-needed 50 /addresses/raw-addresses.txt /addresses/addresses.yaml"
    volumes:
    - ./bin/bash:/bin-mount
    - ...

Could someone please help me to solve this issue? if any more info about my issue needed, let me know then I update my topic as soon as possible. Thanks!