NPM Container Constantly Restarting on Raspberry Pi

I’m attempting to setup Nginx Proxy Manager on my RPi (Raspbian Buster, Release 10). I followed Docker’s instructions for installation and am on the latest version as of two days ago. I was able to generate the Hello World container.

I’m new to Docker but am following the steps on NPM’s website by setting up the Docker Compose Files. However, I am changing the Public HTTP Port to ‘8080:80’, since PiHole (not containerized) currently uses Port 80.
Attempting to follow this tutorial:

My Docker Compose File:

version: '3.8'
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
      # These ports are in format <host-port>:<container-port>
      - '8080:80' # Public HTTP Port
      - '443:443' # Public HTTPS Port
      - '81:81' # Admin Web Port
      # Add any other Stream port you want to expose
      # - '21:21' # FTP

    # Uncomment the next line if you uncomment anything in the section
    # environment:
      # Uncomment this if you want to change the location of
      # the SQLite DB file within the container
      # DB_SQLITE_FILE: "/data/database.sqlite"

      # Uncomment this if IPv6 is not enabled on your host
      # DISABLE_IPV6: 'true'

      - ./data:/data
      - ./letsencrypt:/etc/letsencrypt

When I run docker compose, the container is constantly restarting. When I check the logs, I get the following repeatedly.

s6-svscan: warning: unable to iopause: Operation not permitted 
s6-svscan: warning: executing into .s6-svscan/crash 
s6-svscan crashed. Killing everything and exiting. 
s6-linux-init-hpr: fatal: unable to reboot(): Operation not permitted   

My use case is to simply obtain SSL certificates for some of my locally hosted services. I have PiHole installed directly on my RPi because I set it up years ago and I’m new to Docker, but trying to learn.

I assume you tried to search for the error message. This was my first result for “nginx-proxy-manager unable to iopause”. I hope it helps

Quote from Francisco Bischoff:

try to add this in your compose file:

- seccomp=unconfined

people confirmed it worked

1 Like

Thank you. Unfortunately I overlooked that reddit thread. This did resolve my issue.