Docker Community Forums

Share and learn in the Docker community.

Npm ERR! code EAI_AGAIN

Hello there, Is anyone can help me to resolve this issue?
I’m using Docker version 19.03.13, build 4484c46d9d and docker-compose version 1.8.0, build f3628c7

Updating npm worked for me.

For OSX, Linux - npm install -g npm@latest

For Windows -
Step-1 : Navigate to %ProgramFiles%\nodejs\node_modules\npm and copy the npmrcfile to another folder or the desktop. Then open cmd.exe and run the following commands:

cd %ProgramFiles%\nodejs
npm install npm@latest

Step-2 : Copy the npmrc file back into %ProgramFiles%\nodejs\node_modules\npm.