Docker Community Forums

Share and learn in the Docker community.

Oracle DB fails with ORA-00600 - did you get it running?


(Dhueber) #1

Dear all,

I’m quite new in Docker environment and facing a “small” issue with Oracle DB.

I know that running Oracle DB is not supported on Docker, but for testing purpose I’m building a kind of DBaaS platform based on Docker.

To do so I found a lot interesting blogs about Oracle on Docker. Based on all these information, I build up a Data-only container for the database volumes and an image with Oracle database installed in it.

To deploy a new DB, I’m running a script that download a backup of a DB in the container and runs a restore of it. Unfortunately the restore fails when RMAN tries to shutdown the database due to an ORA-00600 error.

Basically a startup works but a shutdown immediate fails… It looks like a memory or file handler problem…

This is how I run a new container:

docker run -d -P -e TARGET=DBTEST1 --volumes-from=ol7-data --name=ol7-dbtest1 oraclelinux/rdbms

I read some articles saying that due to shared memory management --ipc=host should be used. I tried to but it didn’t help.

Did any of you face such an issue with Oracle in Docker? How do you get the DB running?

Many thanks for any support

Cheers

David