Overlay2 driver problems?


Today i tried to set up Db2 warehouse under docker in a Synology NAS, the db2wh require overlay2 and there is the problem…

i creted the /etc/docker/daemon.json file

“storage-driver”: “overlay2”

but doesn’t really work, the filesystem still btrfs, if i check docker info:

ash-4.3# cat /etc/docker/daemon.json
{ “storage-driver”: “overlay2” }
ash-4.3# docker info
Containers: 2
Running: 1
Paused: 0
Stopped: 1
Images: 2
Server Version: 1.11.2
Storage Driver: btrfs
Logging Driver: db
Cgroup Driver: cgroupfs
Volume: local
Network: bridge null host
Kernel Version: 3.10.102
Operating System:
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.762 GiB
Name: OwO
Docker Root Dir: /volume1/@docker
Debug mode (client): false
Debug mode (server): false
Username: gerithefox
Registry: https://index.docker.io/v1/
WARNING: No kernel memory limit support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support

anyone have any suggestion?

did you change your data-root (defaults to /var/lib/docker) folder to a filesystem supported as backing filesystem (ext4/xfs) and restarted the daemon?


I missed the Synology part: no overlay2 on Synology for time beeing - even though it seems to be supported on the 1819+, the support is broken. On most models, overlay2 is not even an option. Additionaly: why do use still such an old version of Synology’s Docker package? And last but not least the daemon.json is located in a different path and a different name on Synology’s Docker: /var/packages/Docker/etc/dockerd.json

You best bet is to raise a support ticket @Synology. Their docker redistribution is modified and maintained by them.

Thank you for the informations, the problem fixed.

i updated the DSM, put a extra drive into the nas and set up with ext4 then install docker on it, after that edit the correct file what you write down (/var/packages/Docker/etc/dockerd.json)

And now everything works fine.

May i ask which Synology model and DSM version it is? So far I haven’t encountered a single model that worked flawless with overlay2. I know that they all work like charme with btrfs and aufs, but a model with actualy not broken overlay2 support is new to me.