Docker Community Forums

Share and learn in the Docker community.

Panic: "no such file or directory" in Docker toolbox


(Paolougent) #1

Ok, I’m new and not sure where to head for this error. I checked this discussion, but it didn’t help much.

I’m using docker toolbox on Windows 8.1

I’m following this nice tutorial on how to make a container of a django webapp. Everything worked out almost until the end. I run the following:

docker run --publish=8001:8000 paolo/hello_django:latest

And this is what comes out:

panic: standard_init_linux.go:175: exec user process caused “no such file or directory” [recovered]
panic: standard_init_linux.go:175: exec user process caused “no such file or directory”

goroutine 1 [running, locked to thread]:
panic(0x88f8a0, 0xc820124d20)
/usr/local/go/src/runtime/panic.go:481 +0x3e6
github.com/urfave/cli.HandleAction.func1(0xc8200ef2e8)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/urfave/cli/app.go:478 +0x38e
panic(0x88f8a0, 0xc820124d20)
/usr/local/go/src/runtime/panic.go:443 +0x4e9
github.com/opencontainers/runc/libcontainer.(*LinuxFactory).StartInitialization.
func1(0xc8200eebf8, 0xc82001a0c8, 0xc8200eed08)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/opencontainers/runc/libcontainer/factory_linux.go:259 +0x136
github.com/opencontainers/runc/libcontainer.(*LinuxFactory).StartInitialization(
0xc820051630, 0x7fd39d996728, 0xc820124d20)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/opencontainers/runc/libcontainer/factory_linux.go:277 +0x5b1
main.glob.func8(0xc82006ea00, 0x0, 0x0)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/main_unix.go:26 +
0x68
reflect.Value.call(0x7f45a0, 0x9a4d88, 0x13, 0x8ebac8, 0x4, 0xc8200ef268, 0x1, 0
x1, 0x0, 0x0, …)
/usr/local/go/src/reflect/value.go:435 +0x120d
reflect.Value.Call(0x7f45a0, 0x9a4d88, 0x13, 0xc8200ef268, 0x1, 0x1, 0x0, 0x0, 0
x0)
/usr/local/go/src/reflect/value.go:303 +0xb1
github.com/urfave/cli.HandleAction(0x7f45a0, 0x9a4d88, 0xc82006ea00, 0x0, 0x0)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/urfave/cli/app.go:487 +0x2ee
github.com/urfave/cli.Command.Run(0x8ee970, 0x4, 0x0, 0x0, 0x0, 0x0, 0x0, 0x9842
40, 0x51, 0x0, …)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/urfave/cli/command.go:191 +0xfec
github.com/urfave/cli.(*App).Run(0xc820001500, 0xc82000a100, 0x2, 0x2, 0x0, 0x0)
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/Godeps/_workspace
/src/github.com/urfave/cli/app.go:240 +0xaa4
main.main()
/tmp/tmp.n151sEscRu/src/github.com/opencontainers/runc/main.go:137 +0xe2
4

I can add also the useless inspect:

“State”: {
“Status”: “exited”,
“Running”: false,
“Paused”: false,
“Restarting”: false,
“OOMKilled”: false,
“Dead”: false,
“Pid”: 0,
“ExitCode”: 2,
“Error”: “”,
“StartedAt”: “2016-11-16T12:36:47.537758517Z”,
“FinishedAt”: “2016-11-16T12:36:47.575430686Z”
},

p.s is there a way to > log.txt the output of docker run? It works with docker inspect {Container_ID} > log.txt, but not with docker run. I had to select the txt from the bash.


(Dockertiger) #2

suggest you can login the container and run the “paolo/hello_django:latest” manully .,maybe you can find why the servcie can’t start .


(Paolougent) #3

Not sure I understood what you mean. Ubuntu container seems to work. Not sure why django fail.


(Dockertiger) #4

from the result of docker inspect , you can get the details of CMD

for example “CMD [“python”, “manage.py”, “runserver”, “0.0.0.0:8000”]”

use the command "docker exec -it container-id /bin/bash " to login the container ,and implement the script(manage.py) manully . you can check what issues happen when run the script .
but if you don’t have the skill for coding the script ,maybe it is difficult to find what happened.


(Paolougent) #5

Thanks for the patience. This does not look as anything good as CMD is null.

“Env”: [
“PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin”,
“DOCKYARD_SRC=hello_django”,
“DOCKYARD_SRVHOME=/srv”,
“DOCKYARD_SRVPROJ=/srv/hello_django”
],
“Cmd”: null,
“Image”: “paolo/hello_django:latest”,
“Volumes”: {
"/srv/logs/": {},
"/srv/media/": {}
},
“WorkingDir”: “/srv/hello_django”,
“Entrypoint”: [
"/docker-entrypoint.sh"
],

I suppose you’re telling me to run Ubuntu 14.04 container and then django from there. Am I right?

I ran

docker run -it Ubuntu:14:04

as well as

docker exec -it container-id /bin/bash/

Actually it is the same to run:

docker start -i container-id

The bash starts, but now I’m confused on what should I look for.


(Dockertiger) #6

“Entrypoint”: [
"/docker-entrypoint.sh"
],

this shell ,it will Launch the django.you will find the details at the shell


(Paolougent) #7

No need to do that as I discovered it was a silly path error. I’m really a n00b.

Thanks for the header anyway.