Docker Community Forums

Share and learn in the Docker community.

Posix_fallocate() issues

beta

(b.enoit.be) #1

Expected behaviour

Building a MySQL container and populate database(s)

Actual behaviour

The container does build correctly but MySQL complains a lot about posix_fallocate()

For example:

database | 2016-05-07T10:33:39.596876Z 1 [ERROR] InnoDB: posix_fallocate(): Failed to preallocate data for file ./mysql/plugin.ibd, desired size 32768 bytes. Operating system error number 38. Check that the disk is not full or a disk quota exceeded. Make sure the file system supports this function. Some operating system error numbers are described at http://dev.mysql.com/doc/refman/5.7/en/ operating-system-error-codes.html

Information

  • pinata diagnose -u
OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.1-beta10
Running diagnostic tests:
[OK]      docker-cli
[OK]      Moby booted
[OK]      driver.amd64-linux
[OK]      vmnetd
[OK]      osxfs
[OK]      db
[OK]      slirp
[OK]      menubar
[OK]      environment
[OK]      Docker
[OK]      VT-x
Docker logs are being collected into /tmp/20160507-122745.tar.gz
Most specific failure is: No error was detected
Your unique id is: 2F8FF0A7-6939-4EDB-A655-AE3726518CA2
Please quote this in all correspondence.

**Update**: this also happens on Docker.app: version v1.11.1-beta11, version v1.11.1-beta12 and version v1.11.1-beta13
  • minimal docker-compose.yaml to reproduce:

    version: "2"
    services:
    database:
    image: mysql
    container_name: database
    ports:
    - "3306:3306"
    volumes
    - ./database:/var/lib/mysql
    environment:
    MYSQL_ROOT_PASSWORD: root
    MYSQL_DATABASE: test

  • host distribution and version : Mac OSX 10.11.4

Steps to reproduce the behavior

  1. You just need to docker-compose up the above file

1.11.1-beta10 (build: 6662) Mysql db migration schema but no data
(Dave Tucker) #2

Thanks for the report! This is being tracked on our internal tracker as bug (#3098).
I’m hopeful that someone will look in to this soon!
Keep the feeback coming, and thanks for testing Docker for Mac!


(Denis Andrejew) #3

Same issue! Using percona:5.7 image, Docker for Mac beta12, OS X 10.10.5.

Looking forward to a resolution! Keep up the good work!


(Sergey Maltsev) #4

Same issue with mysql 5.7 on OS X 10.11.5


(Kgorskowski) #5

Running into this problem when setting up an environment for Craft CMS with docker-compose with linked php-fpm and MySQL containers.
The initial installation routine of Craft is incomplete/corrupt and I’m getting the error message mentioned in the original post.
Environment:
OS X: version 10.11.5 (build: 15F34)
Docker.app: version v1.11.1-beta13.1
container mysql:latest

UPDATE: just to add this aspect, after I switched to mysql:5.6 everything worked flawlessly


(Jim Myhrberg) #6

Same issue here too. Are there any more news about a fix for this issue?

I just ran into it with the mysql:latest image. It seemed to be fine to begin with, but once I started importing data, MySQL just grinded to a halt and stopped responding over TCP after a few minutes. Neither docker stop or docker kill worked either, but quitting Docker.app worked at least.

For now I’ve resorted to just using a named volume instead of mounting a host directory, which seems to work just fine.

OS X: 10.11.5 (15F34)
Docker.app: 1.11.1-beta13.1
Image: mysql:latest