Docker Community Forums

Share and learn in the Docker community.

Postgres pgadmin bug


(Bono Yoon) #1

Postgresql conneted well between host and container.

But, Everytime I get this error message on pgamin3 when I click Schemas --> public.

Error Invalid message format

  1. Docker version

PS C:\Users\BONO> docker version
Client:
Version: 1.12.0-rc4
API version: 1.24
Go version: go1.6.2
Git commit: e4a0dbc
Built: Wed Jul 13 03:28:51 2016
OS/Arch: windows/amd64
Experimental: true

Server:
Version: 1.12.0-rc4
API version: 1.24
Go version: go1.6.2
Git commit: e4a0dbc
Built: Wed Jul 13 03:28:51 2016
OS/Arch: linux/amd64
Experimental: true

  1. host OS Windows 10

  2. Container OS

cat /proc/version

Linux version 4.4.15-moby (root@e21550224ebb) (gcc version 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2) ) #1 SMP Tue Jul 12 14:03:08 UTC 2016

  1. Postgres Version

postgres=# select version();
version

PostgreSQL 9.4.8 on x86_64-unknown-linux-gnu, compiled by gcc (Debian 4.9.2-10) 4.9.2, 64-bit

  1. Pgamdin version 1.22.1

(Micnigh) #2

I recieved this error as well, and it seems to be related to the post here

One workaround is to connect to a hostname of ‘docker’ instead of ‘localhost’