Problem starting docker desktop (while Podman is running)

When I try to start Docker Desktop, I get an error message. A prompt says:
Something went wrong
Setting up docker api proxy listener: open \.\pipe\docker_engine: Access is denied.

I have tried reinstalling, but I still get the message.

Running “docker version” displays a similar error message:
error during connect: this error may indicate that the docker daemon is not running: Get “http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/version”: open //./pipe/docker_engine: The system cannot find the file specified.

I have installed Docker Desktop 4.27.2 using the installer
I’m on Windows 11 Enterprise

Update:
Irealized it might have something to do with me installing Podman on the computer, for another project. Simply closing Podman becore opening Docker Desktop seems to fix the problem

Docker Desktop and Podman Desktop is for the same purpose and Podman tries to show itself as Docker even on Linux without desktops. Docker Desktop and Podman Desktop both creates a virtual machine but Podman DEsktop and Docker Desktop are still not compatible. On macOS I could install Podman and disable using the default context. I can’t see that option on Windows. I would ask about it on a Podman forum.