Docker Community Forums

Share and learn in the Docker community.

Pull works, run does not

docker
beta

(Themodem) #1

Expected behavior

docker run hello-world should output anything

Actual behavior

No output for any docker run commands

Information

When running docker run the terminal just sits there until ctrl+c is pressed. There is no stdout or stderr

https://www.dropbox.com/s/jwcfobafq467y3u/debug.txt?dl=0 - Output from DockerDebugInfo.ps1

https://www.dropbox.com/s/hhi13f30y2mdy2z/docker.png?dl=0 - Screenshot

Not that you can tell from the screenshot but I have pressed enter after the command :smile:

Steps to reproduce the behavior

  • docker pull hello-world
  • docker run hello-world

or docker run anything at all


(Rolf Neugebauer) #2

Hi @themodem

I’ve tried reproducing this and it works for me ™.

I can’t access the debug output you linked to so I can’t be for sure, but we had (and still) have a number of networking issues and sone of them could result in the behaviour you are seeing. Some of the issues should be fixed in the next Beta (coming out today) and we hope to have a fix for the remaining issues for the Beta scheduled for next week.

The debug output would be very helpful

Thanks for the feedback.
Rolf


(Brianvallelunga) #3

I’m seeing the same issue here. I’m running the latest build as of May 11, 2016 (version 1.11.1-beta11 build 2789). Initially I did get more information about it pulling down an image. But then it just sits and doesn’t output anything.

My logs simply show:

[14:13:34.364][Proxy ][Info ] proxy >> POST /v1.23/containers/create [rewriteBinds]
[14:13:34.366][Proxy ][Info ] proxy >> POST /v1.23/containers/create
[14:13:34.367][Proxy ][Info ] Dial 10.0.75.2:2375
[14:13:34.368][Proxy ][Info ] Dial IP 10.0.75.2:2375
[14:13:34.442][Proxy ][Info ] proxy << POST /v1.23/containers/create
[14:13:34.444][Proxy ][Info ] proxy >> POST /v1.23/containers/87e519526619cd7d5f56343a067deb11539ed8e1e643af4a54192768051c6644/attach?stderr=1&stdout=1&stream=1
[14:13:34.445][Proxy ][Info ] Dial 10.0.75.2:2375
[14:13:34.446][Proxy ][Info ] Dial IP 10.0.75.2:2375


(Tutnes) #4

I have the same issue. I can do docker pull, and it will work.
And I can do docker run with -d as an option and it works (with the exception of ubuntu and debian container)
But anything I have tried with a plain docker run will not work.

Latest log entries:
[23:49:34.761][Proxy ][Info ] proxy << POST /v1.23/containers/create
[23:49:34.764][Proxy ][Info ] proxy >> POST /v1.23/containers/63206a66c4afb614f85c440540dc6b0d3bfe7df9b08362463686456fd6beeb13/start [start]
[23:49:34.767][Proxy ][Info ] proxy >> POST /v1.23/containers/63206a66c4afb614f85c440540dc6b0d3bfe7df9b08362463686456fd6beeb13/start
[23:49:34.769][Proxy ][Info ] Dial 10.0.75.2:2375
[23:49:34.771][Proxy ][Info ] Dial IP 10.0.75.2:2375
[23:49:35.110][Proxy ][Info ] proxy << POST /v1.23/containers/63206a66c4afb614f85c440540dc6b0d3bfe7df9b08362463686456fd6beeb13/start
[23:49:39.188][Proxy ][Info ] proxy >> GET /v1.23/containers/json
[23:49:39.191][Proxy ][Info ] Dial 10.0.75.2:2375
[23:49:39.193][Proxy ][Info ] Dial IP 10.0.75.2:2375
[23:49:39.197][Proxy ][Info ] trying to rewrite IP addresses for port mapping for 63206a66c4afb614f85c440540dc6b0d3bfe7df9b08362463686456fd6beeb13 []types.Port{types.Port{IP:"", PrivatePort:6699, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:6698, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:2021, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:2020, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:9998, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:9911, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:8021, PublicPort:0, Type:“tcp”}, types.Port{IP:"", PrivatePort:8020, PublicPort:0, Type:“tcp”}}
[23:49:39.200][Proxy ][Info ] proxy << GET /v1.23/containers/json
[23:49:47.998][Proxy ][Info ] Handle DNS query ;; opcode: QUERY, status: NOERROR, id: 61617 ;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.17.172.in-addr.arpa. IN PTR
[23:49:48.000][Proxy ][Info ] Search for dns server…
[23:49:48.105][Proxy ][Info ] Server: router.asus.com
[23:49:48.107][Proxy ][Info ] Address: 192.168.1.1
[23:49:48.108][Proxy ][Info ]
[23:49:48.111][Proxy ][Info ]
[23:49:48.113][Proxy ][Info ] Found dns server 192.168.1.1
[23:49:48.115][Proxy ][Info ] Forward DNS query on udp to 192.168.1.1:53
[23:49:48.117][Proxy ][Info ] Got response ;; opcode: QUERY, status: NXDOMAIN, id: 61617 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.17.172.in-addr.arpa. IN PTR ;; AUTHORITY SECTION: 17.172.in-addr.arpa. 3600 IN SOA localhost. root. 1 604800 86400 2419200 604800
[23:49:48.120][Proxy ][Info ] Handle DNS query ;; opcode: QUERY, status: NOERROR, id: 6329 ;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.17.172.in-addr.arpa. IN PTR
[23:49:48.122][Proxy ][Info ] Forward DNS query on udp to 192.168.1.1:53
[23:49:48.124][Proxy ][Info ] Got response ;; opcode: QUERY, status: NXDOMAIN, id: 6329 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.17.172.in-addr.arpa. IN PTR ;; AUTHORITY SECTION: 17.172.in-addr.arpa. 3600 IN SOA localhost. root. 1 604800 86400 2419200 604800
[23:49:48.202][Proxy ][Info ] Handle DNS query ;; opcode: QUERY, status: NOERROR, id: 23568 ;; flags: rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.0.0.1.1.e.f.f.f.c.a.2.4.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa. IN PTR
[23:49:48.204][Proxy ][Info ] Forward DNS query on udp to 192.168.1.1:53
[23:49:48.222][Proxy ][Info ] Got response ;; opcode: QUERY, status: NXDOMAIN, id: 23568 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0 ;; QUESTION SECTION: ;2.0.0.0.1.1.e.f.f.f.c.a.2.4.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa. IN PTR ;; AUTHORITY SECTION: ip6.arpa. 3600 IN SOA b.ip6-servers.arpa. hostmaster.icann.org. 2015123416 1800 900 604800 3600