Raspberry Pi 4B, Raspberry Pi OS (64-bit), Portainer CE v2.19.4, Docker v24.0.7

If I run the command

sudo docker run -d --name=grafana -p 3000:3000 grafana/grafana

on my Raspberry Pi 4

Raspberry Pi OS with desktop

  • Release date: December 5th 2023
  • System: 64-bit
  • Kernel version: 6.1
  • Debian version: 12 (bookworm)

the system responds as follows:

Unable to find image ‘grafana/grafana:latest’ locally
latest: Pulling from grafana/grafana
docker: no matching manifest for linux/arm/v8 in the manifest list entries.
See ‘docker run --help’.

How can the problem be fixed as I actually want to use portainer and more docker containers like Telegraf and InfluxDB v1.8 (InfluxDB2 not working)?

Thanks for your ideas in advance.

You can try

sudo docker run -d --name=grafana -p 3000:3000 --platform linux/arm64 grafana/grafana

The grafana image doesn’t support the architecture your system reports about itself. Although some sources indicates linux/arm/v8 is 64 bit and equivalent to linux/arm64, accoding to the wiki page of ARM architetcure family, not all ARMv8 supports 64 bit:

Thank you for your quick response. I tried it but it did not work properly. Another version named “grafana/grafana-enterprise:10.1.2” worked.

Thanks for the feedback. That is interesting, since that supports the same arm64 architecture so I have no idea what the difference is.

Note: I don’t think the enterprise version is what you need. It probably requires Grafana subscription.